InstaDebit / iDebit / Interac Timeouts
Incident Report for ParamountCommerce
Resolved
This incident has been resolved.
Posted May 08, 2022 - 09:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2022 - 08:31 EDT
Investigating
We are investigating an issue impacting iDebit / instadebit / Interac
Posted May 08, 2022 - 08:18 EDT
This incident affected: INTERAC®, iDebit, and INSTADEBIT.