Service Outage
Incident Report for ParamountCommerce
Resolved
This incident has been resolved.
Posted May 08, 2022 - 05:44 EDT
Monitoring
TD Canada Trust is currently experiencing a service outage which is impacting our services.
Our team is currently monitoring until performance levels return to normal.

We apologize for any inconvenience.
Posted May 08, 2022 - 03:16 EDT
This incident affected: INTERAC®.